본문내용 바로가기 메인메뉴 바로가기 하단내용 바로가기

자료실 게시판

자료실 게시판 상세보기
리눅스 Ghost 취약점 보안 업데이트 권고2015.01.28

 ※ ‘15. 1. 30. 업데이트 내용 : 첨부문서(리눅스 Ghost 취약점 대응방안 권고 v2.pdf)에 영향 받는 플랫폼 OS, FAQ 추가

 

□ 개요

  • 미국 US-CERT는 리눅스 GNU C 라이브러리(glibc)에서 임의코드를 실행할 수 있는 취약점(CVE-2015-0235)이 발견되었다고 발표
  • CVE-2015-0235는 해당 라이브러리의 gethostbyname( ) 함수 처리 과정에서 발생하는 버퍼오버플로우 취약점
  • GNU C 라이브러리 : 리눅스 계열 운영체제에서 기본적으로 사용하는 소프트웨어

 

 

□ 취약점 내용

  • 라이브러리에 존재하는 특정 함수(__nss_hostname_digits_dots( ))의 잘못된 메모리 사용으로 인해 오버플로우가 발생하여 프로그램의 실행 흐름 변경이 가능

  * __nss_hostname_digits_dots( ) 함수 : 도메인 주소를 IP 주소로 변환할 때 사용하는 함수인gethostbyname( )를 호출 시 내부적으로 호출되는 함수

 

 

□ 해당 시스템

  • 영향을 받는 시스템
    • - glibc 2.2~2.17버전의 모든 리눅스 시스템

 

 

□ 해결 방안

  • 취약한 버전의 라이브러리를 사용하는 시스템은 상위 버전으로 업데이트

※ 실행파일에 취약한 버전의 라이브러리를 포함하여 컴파일 한 경우, 상위 버전의 라이브러리로 재컴파일 하여 설치 필요

  • 다음 참고사이트의 내용을 참조하여 보안업데이트 수행

- CentOS [1]

- Debian [2]

- Redhat [3]

- Ubuntu [4]

 

□ 기타 문의사항

  • 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

 

 

[참고사이트]

[1] http://lists.centos.org/pipermail/centos/2015-January/149413.html

[2] https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=776391

[3] https://access.redhat.com/articles/1332213

[4] http://www.ubuntu.com/usn/usn-2485-1/

첨부파일 [KISA]리눅스_Ghost_취약점_대응방안_권고_v2.pdf
키워드 Ghost , 취약점 , 리눅스