본문내용 바로가기 메인메뉴 바로가기 하단내용 바로가기

보안공지

보안공지 상세보기
Pivotal Spring 제품 취약점 업데이트 권고2018.03.12

□ 개요
 o Pivotal社의 Spring Data REST와 Spring boot의 취약점을 해결한 보안 업데이트 권고
 
□ 주요 내용
 o JSON 데이터에 대한 입력값 검증 오류로 인해 발생하는 원격 코드 실행 취약점(CVE-2017-8046)[1]

□ 영향을 받는 제품 및 버전
 o Spring Data REST
   - 2.6.8 이하 버전
   - 3.0.0 버전
 o Spring Boot
   - 2.0.0M4 이하 버전
 
□ 해결 방안
 o Spring 공식 홈페이지에서 최신버전으로 업데이트
   - Spring Data REST 2.6.9(Ingalls SR9) 버전
   - Spring Data REST 3.0.1(Kay SR1) 버전
   - Spring Boot 1.5.9 버전
   - Spring Boot 2.0 M6 버전
 
□ 용어 정리
 o Spring Data REST : Spring Data 프로젝트 중 하나로, HTTP와 Spring Data 저장소를 사용하는 지속성 모델에서 데이터

    처리 기능을 수행
 o Spring Boot : 산업용 스프링 기반 응용 프로그램을 생성하기 위한 Spring의 솔루션
 
□ 기타 문의사항
 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118
 
[참고사이트]
 [1] http://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2017-8046
 [2] https://pivotal.io/security/cve-2017-8046