본문내용 바로가기 메인메뉴 바로가기 하단내용 바로가기

보안공지

보안공지 상세보기
Apache Tomcat 신규 취약점 보안 업데이트 권고2017.10.10

□ 개요
 o Apache 소프트웨어 재단은 Apache Tomcat에 영향을 주는 원격 코드 실행 취약점을 해결한 보안 업데이트 발표
 o 취약점 버전을 사용 중일 경우 웹 쉘 업로드로 인한 피해가 발생할 수 있으므로 서버의 담당자는 해결 방안에 따라

    최신 버전으로 업데이트 권고
 
□ 설명
 o 서버에서 HTTP PUT 메소드를 사용하도록 설정한 경우 특수하게 조작된 Request 요청을 통해 JSP 파일을 서버에 업로드할

    수 있는 원격 코드 실행 취약점(CVE-2017-12617)
 
□ 영향을 받는 버전
 o Apache Tomcat 9.0.0.M1 - 9.0.0
 o Apache Tomcat 8.5.0 ~ 8.5.22
 o Apache Tomcat 8.0.0.RC1 ~ 8.0.46
 o Apache Tomcat 7.0.0 ~ 7.0.81

□ 해결 방안
 o Apache Tomcat 9.x 버전 사용자
   - Apache Tomcat 9.0.1 버전으로 업그레이드 [1]
 o Apache Tomcat 8.x 버전 사용자
   - Apache Tomcat 8.0.47 버전 혹은 8.5.23 버전으로 업그레이드 [2]
 o Apache Tomcat 7.x 버전 사용자
   - Apache Tomcat 7.0.82 버전으로 업그레이드 [3]
 
□ 기타 문의사항
 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118

[참고사이트]
 [1] http://tomcat.apache.org/security-9.html
 [2] http://tomcat.apache.org/security-8.html
 [3] http://tomcat.apache.org/security-7.html

키워드 apache tomcat