본문내용 바로가기 메인메뉴 바로가기 하단내용 바로가기

보안공지

보안공지 상세보기
Samba 취약점 보안 업데이트 권고2017.09.22
□ 개요
 o Samba 소프트웨어에서 발생하는 취약점을 해결한 보안 업데이트를 발표[1]
 o 낮은 버전 사용자는 서비스 거부 공격 및 중간자 공격에 취약할 수 있어 해결방안에 따라 최신 버전으로 업데이트 권고

□ 설명
 o SMBv1,v2,v3 사용 시, 일부 기능에서 클라이언트 인증을 하지 않아 중간자 공격이 가능한 취약점(CVE-2017-12150)[2]
 o SMBv3 사용 시, DFS(Distribute File System, 분산 파일 시스템)의 통신에서 미흡한 데이터 암호화로 인해
    중간자 공격이 가능한 취약점(CVE-2017-12151)[3]
 o SMBv1 사용 시, 잘못된 데이터 요청으로 인해 클라이언트에서 서버 메모리 정보를 노출시킬 수 있는 취약점(CVE-2017-12163)[4]

□ 영향받는 소프트웨어
발생한 취약점 취약한 버전
CVE-2017-12150 Samba 3.0.25 ~ 4.6.7
CVE-2017-12151 Samba 4.1.0 ~ 4.6.7
CVE-2017-12163 Samba 4.7.0을 제외한 모든 버전
   ※ Samba 4.7.0은 해당 취약점 패치 이후 배포된 버전이므로 영향 받지 않음
 
□ 해결 방안
 o Samba 4.4.15 및 이전 버전 사용자
    - Samba 4.4.15 및 이전 버전 사용자는 4.4.16 버전으로 업데이트 적용[5]
 o Samba 4.5.13 사용자
    - Samba 4.5.13 사용자는 4.5.14 버전으로 업데이트 적용[6]
 o Samba 4.6.7 사용자
    - Samba 4.6.7 사용자는 4.6.8 버전으로 업데이트 적용[7]
 
□ 용어 설명
 o 중간자 공격 (Man-In-The-Middle) : 통신하고 있는 장비들 사이에서 데이터를 변경하거나 도청하여 통신 내용을 조작하는 해킹 기법
 
□ 기타 문의사항
 o 한국인터넷진흥원 인터넷침해대응센터: 국번 없이 118

[참고사이트]
[1] https://www.samba.org/samba/history/
[2] https://www.samba.org/samba/security/CVE-2017-12150.html
[3] https://www.samba.org/samba/security/CVE-2017-12151.html
[4] https://www.samba.org/samba/security/CVE-2017-12163.html
[5] https://download.samba.org/pub/samba/patches/samba-4.4.15-4.4.16.diffs.gz
[6] https://download.samba.org/pub/samba/patches/samba-4.5.13-4.5.14.diffs.gz
[7] https://download.samba.org/pub/samba/patches/samba-4.6.7-4.6.8.diffs.gz
 
키워드 samba