본문내용 바로가기 메인메뉴 바로가기 하단내용 바로가기

보안공지

보안공지 상세보기
Apache Log4j 역직렬화 취약점 업데이트 권고2017.04.19
□ 개요
 o Apache Log4j에서 임의 코드 실행이 가능한 취약점을 해결한 보안 업데이트 발표 [1]
 o 취약한 버전을 사용 중인 서버의 담당자는 해결방안에 따라 최신 버전으로 업데이트 권고
 
□ 내용
 o Log4j모듈이 로그 이벤트를 역직렬화 하는 과정에서 임의 코드 실행이 가능한 취약점(CVE-2017-5645)
 
□ 영향을 받는 버전
 o Apache Log4j 2.0-alpha1 ~ 2.8.1 버전
 
□ 해결 방안
 o Apache Log4j 2.8.2 버전으로 업데이트 수행[2]
 o socket server class 사용 금지
 o AbstractSocketServer에 클래스 필터링 추가
 
□ 용어 정리
 o Log4j : 프로그램을 작성하는 도중에 로그를 남기기 위해 사용되는 자바 기반 로깅 유틸리티
 
□ 기타 문의사항
 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118
 
[참고사이트]
 [1] https://issues.apache.org/jira/browse/LOG4J2-1863
 [2] https://git-wip-us.apache.org/repos/asf?p=logging-log4j2.git;h=5dcc192
 
키워드 Apache