본문내용 바로가기 메인메뉴 바로가기 하단내용 바로가기

보안공지

보안공지 상세보기
Apache Tomcat 신규 취약점 보안 업데이트 권고2017.04.13

□ 개요
 o Apache 소프트웨어 재단은 Apache Tomcat에 영향을 주는 서비스 거부, 정보 노출 취약점을 해결한 보안 업데이트 발표
 o 취약한 버전을 사용 중인 서버의 담당자는 해결방안에 따라 최신 버전으로 업데이트 권고
 
□ 내용
 o 이전 파일 전송에 대한 처리가 완료될 때 파이프라인 된 요청이 손실되면서 잘못된 요청에 응답이 전송되어 발생하는 정보

    노출 취약점(CVE-2017-5647)
 o Security Manager 클래스에서 신뢰할 수 없는 응용 프로그램 실행 중 잘못된 객체 참조로 인해 다른 웹 응용 프로그램의

    정보에 접근 가능한 정보 노출 취약점(CVE-2017-5648)
 o HTTP/2 통신 과정에서 WINDOW_UPDATE 프레임을 기다리는 GOAWAY 프레임에 대해 스트림을 종료하지 않아 발생하는

    서비스 거부 취약점(CVE-2017-5650)
 o 파일 전송 시 동일한 프로세서가 여러 요청에 사용되면서 요청에 다른 응답이 전송될 수 있는 정보 노출 취약점

   (CVE-2017-5651)
 
□ 영향을 받는 제품 및 버전
 o CVE-2017-5647 취약점
  - Apache Tomcat 9.0.0.M1 ~ 9.0.0.M17
  - Apache Tomcat 8.5.0 - 8.5.12
  - Apache Tomcat 8.0.0.RC1 ~ 8.0.42
  - Apache Tomcat 7.0.0 - 7.0.76
 o CVE-2017-5648 취약점
  - Apache Tomcat 9.0.0.M1 ~ 9.0.0.M17
  - Apache Tomcat 8.5.0 ~ 8.5.11
  - Apache Tomcat 8.0.0.RC1 ~ 8.0.41
  - Apache Tomcat 7.0.0 ~ 7.0.75
 o CVE-2017-5650 및 CVE-2017-5651 취약점
  - Apache Tomcat 9.0.0.M1 ~ 9.0.0.M18
  - Apache Tomcat 8.5.0 ~ 8.5.12
 
□ 해결 방안
 o Apache Tomcat 9.x 버전 사용자
  - Apache Tomcat 9.0.0.M19 버전으로 업그레이드 [1]
 o Apache Tomcat 8.5.x 버전 사용자
  - Apache Tomcat 8.5.13 버전으로 업그레이드 [2]
 o Apache Tomcat 8.0.x 버전 사용자
  - Apache Tomcat 8.0.43 버전으로 업그레이드 [2]
 o Apache Tomcat 7.x 버전 사용자
  - Apache Tomcat 7.0.77 버전으로 업그레이드 [3]
 
□ 용어 정리
 o WINDOW_UPDATE 프레임 : HTTP/2 기능 중 하나인 Flow Control 구현을 위해 사용되는 프레임
 o GOAWAY 프레임 : HTTP/2 통신에서 맺어져 있는 연결을 종료시키거나, 심각한 오류를 알려주는데 사용하는 프레임
 
□ 기타 문의사항
 o 한국인터넷진흥원 인터넷침해대응센터: 국번없이 118
 
[참고사이트]
 [1] http://tomcat.apache.org/security-9.html

 [2] http://tomcat.apache.org/security-8.html
 [3] http://tomcat.apache.org/security-7.html

키워드 Apache , Tomcat